Some Forge apps experiencing increased Jira API rate limiting errors (429)

Incident Report for Atlassian Developer

Update

We continue to see improvements in error rates, and our teams are evaluating further mitigation to expedite resolution.
Posted Apr 22, 2026 - 23:29 UTC

Update

After the initial remediation, we are seeing improvements and our teams continue to monitor the situation closely to confirm stability.

We will share further updates within the next 8 hours, or sooner if there are any major developments.
Posted Apr 22, 2026 - 16:21 UTC

Identified

Our teams have implemented initial remediation by increasing certain rate limits, and we will continue to monitor the situation closely to confirm stability. We will share further updates within the next 8 hours, or sooner if we have any meaningful developments to report.
Posted Apr 22, 2026 - 08:53 UTC

Investigating

We are aware that some Forge apps are experiencing an increased number of 429 Too Many Requests errors when making calls to the Jira REST API.
This is causing disruption for end users of affected apps.
Confluence APIs are not impacted.

If your app is impacted by this issue, the 429 response will contain the following headers:

X-Failure-Category: FAILURE CLIENT RATE LIMITED
X-Ratelimit-Limit: 360000
X-Ratelimit-Remaining: 0

Note that this gateway-level rate limiting does not return a Retry-After header. You can use the X-Ratelimit-Reset header to determine when the rate limit window resets and implement a backoff strategy accordingly.

Our teams are investigating this issue with urgency, and we will provide an update within two hours.
Posted Apr 22, 2026 - 06:57 UTC
This incident affects: APIs (Jira Cloud APIs).