Forge app deployments are failing for some apps

Incident Report for Atlassian Developer

Resolved

Forge app deployments have been working correctly since 21:30 Jun 25th UTC.
Posted Jun 27, 2025 - 10:29 UTC

Monitoring

We have mitigated deployment issues - all deployments are working correctly since 21:30 UTC.
We are monitoring the system to ensure that the underlying conditions will not re-appear.
Posted Jun 25, 2025 - 21:46 UTC

Investigating

We are investigating an incident causing app deployments to fail with the CLI error message 'Error: Deployment failed'. We will post next update in 30 minutes.
Posted Jun 25, 2025 - 20:42 UTC
This incident affected: Developer (App Deployment).